diff options
author | Stan Seibert <stan@mtrr.org> | 2013-03-29 12:29:46 -0400 |
---|---|---|
committer | tlatorre <tlatorre@uchicago.edu> | 2021-05-09 08:42:39 -0700 |
commit | 8549ed651b060f5d42358086085afc0b3d885dc4 (patch) | |
tree | c3f23f84a26cef6d52d0b5187b997208278af5b2 /setup.py | |
parent | 7adb46b7598a8222d9d5ff0bbd00ef0e4a89a4cd (diff) | |
download | chroma-8549ed651b060f5d42358086085afc0b3d885dc4.tar.gz chroma-8549ed651b060f5d42358086085afc0b3d885dc4.tar.bz2 chroma-8549ed651b060f5d42358086085afc0b3d885dc4.zip |
Add location of pyublas headers to include path
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 13 |
1 files changed, 13 insertions, 0 deletions
@@ -25,7 +25,20 @@ try: except OSError: clhep_libs = [] + include_dirs=['src'] + +##### figure out location of pyublas headers +try: + from imp import find_module + file, pathname, descr = find_module("pyublas") + from os.path import join + include_dirs.append(join(pathname, "include")) +except: + pass # Don't throw exceptions if prereqs not installed yet + +##### + if 'VIRTUAL_ENV' in os.environ: include_dirs.append(os.path.join(os.environ['VIRTUAL_ENV'], 'include')) try: |